Do NOT use c:\windows\ for the Kaseya agent working Directory

PROBLEM
You are seeing various problems with agent behaviour, including, but not limited to

  • Audit Data not being returned
  • KSDU scans not returning data
  • Domain Watch not returning data
  • KAV updates not working
  • Agent procedures failing with "permissions" errors


CAUSE
The agent working directory (Agent tab -> Working Directory), is set to c:\windows, or a subdirectory, such as c:\windows\temp, or c:\windows\kworking
The Windows directory has very restrictive permissions and as such, using this directory or sub-directories as a location for the Kaseya working directory should never be used.


WORKAROUND / RESOLUTION
Leave the default setting on the Agent Tab -> Working directory page as c:\kworking, or feel free to change to c:\MyCorpTemp, but do not use c:\windows\, or c:\program files\ for this setting.

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