Problem
Testing agent credential fails on Agent > Set Credential page, but credentials have been confirmed to be valid.
Cause
Kaseya Agent service was running as a user, when it should run as SYSTEM account.
Solution
Open Windows services manager (services.msc), go into properties of "Kaseya Agent" service, and ensure it is set to run as local system (see below). Then restart the service, check in Task Manager that its now running as system, and re-try the credential test.
Applies to
Kaseya VSA - all versions