Problem
KLC shows connecting or session ended on machines that are correctly provisioned and Kaseya Endpoint service is running.
Cause
1. Collect the target machine logs. Check the Endpoint logs for the target machine.
You can find the endpoint logs at the following locations
- Windows XP and 2003: C:\Documents and Settings\All Users\Application Data\Kaseya\Log\Endpoint
- Windows Vista and later: C:\ProgramData\Kaseya\Log\Endpoint\
- OSx: /Library/Logs/com.kaseya/Endpoint/
2. Open the log file and search for the following error:
"Session jwt was NOT validated - the session will not continue"
Example
[E 2018-04-05T23:34:07.619724Z -07:00 3104 10c4] [AgentRemoteControlSession] Session jwt was NOT validated - the session will not continue
If you notice the following error in the endpoint logs of the target machine, it means the timezone of the endpoint is not set properly.
Resolution
Please correctly set the timezone of the machine and check if KLC is working now.
Please note: Please follow this article only if the error is as described above.