Follow

Backup process fails because of missing .NET dependency

Problem

Any of the following symptoms may occur: -

1) Backup client installation cannot be verified (but Acronis was installed successfully)

2) backups fail with this error

Backup failed - No log file was collected for this backup event. It is likely that the Acronis process crashed.

3) errors are logged on the offsite server for agents with "synthetic full" option configured: -

Synthetic Full Backup failed during set setname on the offsite server agentID. The full file will be transferred to the offsite server. The error received was: Failed to find the offsite synthetic full backup file.

or

Incremental backup processing failed for volBackup2.TIB in set setname for machine agentID. No further incremental backups will be replicated offsite for this set, but incremental backups replicated before this message are valid. It is not possible to create an offsite synthetic full backup from this set, so the next full backup will be a non-synthetic full backup.

Cause

Kaseya Backup requires .NET 3.5 framework to be installed on backup agents and offsite servers with "synthetic full support". If it is not installed, or the installation is corrupt, the below exception will be logged in the Windows application event log at the same time the backup task fails: -

1.png

 

Resolution

  • use the OS-specific steps below to install .NET 3.5
  • if .NET 3.5 is already installed, reinstall it
  • if the exceptions still occur, contact Microsoft support for further assistance

 

Windows Server 2012:  -

  • in Server Manager, go to Manage > Add Roles and Features
  • navigate to Features tab of wizard and select .NET Framework 3.5 (inlcudes .NET 2.0 and 3.0)

Windows 8.x: -

  • go to Control Panel > Programs > Turn Windows Features on or off
  • select .NET Framework 3.5 (inlcudes .NET 2.0 and 3.0)

Windows  Server 2008: -

  • in Server Manager, go to Features > Add Features
  • select .NET Framework 3.5.1

Windows 7: -

  • go to Control Panel > Programs > Turn Windows Features on or off
  • select Microsoft .NET Framework 3.5.1

Windows XP or Server 2003: -

  • download and run "Microsoft .NET Framework 3.5 Service pack 1 (Full Package)" from Microsoft - http://www.microsoft.com/en-gb/download/details.aspx?id=25150

Applies to

Kaseya VSA (Backup module) - v6.5 and higher

Was this article helpful?
0 out of 0 found this helpful
Have more questions? Submit a request

0 Comments

Article is closed for comments.