Microsoft VSS Troubleshooting

PROBLEM
Backups fail with VSS related issues.

CAUSES
Various reasons, usually Windows related.

SOLUTION
Kaseya does not provide technical support for Volume Shadow Copy Service (VSS), which is a Windows operating system component. If a Kaseya product issue is determined to be caused by VSS failure, the problem must be addressed to Microsoft and/or researched using their support resources. The troubleshooting steps described below have been documented on Microsoft's support site or community forums, but have not been tested or validated by Kaseya.

Symptoms of VSS Malfunction:

  1. Very long VSS snapshot generation time with high hard drive activity.
  2. VSS errors reported in the Event Viewer 
  3. VSS fails to create snapshots.
  4. Kaseya Backup fails to run: https://helpdesk.kaseya.com/entries/100066213-Kaseya-Backup-VSS-troubleshooting-guide

 

VSS Troubleshooting Tip #1

Usually, servers that haven't been rebooted in a while cause VSS to malfunction. As such, we recommend attempting a reboot before proceeding to the next steps.

 

VSS Troubleshooting Tip #2

You can try to re-register all VSS and COM components. WARNING: The following steps are to be used only by advanced users. These commands modify low-level functionality and pre-requisite components of the Windows Volume Shadow Copy Service as well as the VSS service itself.

 

Windows XP ONLY

  1. Open Command Prompt
  2. Type: CD %WINDIR%\System32 and hit enter.
  3. Run the following commands in order:

    Net stop vss
    Net stop swprv
    regsvr32 ole32.dll
    regsvr32 vss_ps.dll
    Vssvc /Register
    regsvr32 /i swprv.dll
    regsvr32 /i eventcls.dll
    regsvr32 es.dll
    regsvr32 stdprov.dll
    regsvr32 vssui.dll
    regsvr32 msxml.dll
    regsvr32 msxml3.dll
    regsvr32 msxml4.dll ​

  4. Reboot the computer.

 

Windows 7, Windows 8, Server 2008/R2, and Server 2012 ONLY

 

  1. Open Command Prompt
  2. Type: CD %WINDIR%\System32 and hit enter.
  3. Run the following commands in order:

    net stop "System Event Notification Service"
    net stop "Background Intelligent Transfer Service"
    net stop "COM+ Event System"
    net stop "Microsoft Software Shadow Copy Provider"
    net stop "Volume Shadow Copy"
    cd /d %windir%\system32
    net stop vss
    net stop swprv
    regsvr32 /s ATL.DLL
    regsvr32 /s comsvcs.DLL
    regsvr32 /s credui.DLL
    regsvr32 /s CRYPTNET.DLL
    regsvr32 /s CRYPTUI.DLL
    regsvr32 /s dhcpqec.DLL
    regsvr32 /s dssenh.DLL
    regsvr32 /s eapqec.DLL
    regsvr32 /s esscli.DLL
    regsvr32 /s FastProx.DLL
    regsvr32 /s FirewallAPI.DLL
    regsvr32 /s kmsvc.DLL
    regsvr32 /s lsmproxy.DLL
    regsvr32 /s MSCTF.DLL
    regsvr32 /s msi.DLL
    regsvr32 /s msxml3.DLL
    regsvr32 /s ncprov.DLL
    regsvr32 /s ole32.DLL
    regsvr32 /s OLEACC.DLL
    regsvr32 /s OLEAUT32.DLL
    regsvr32 /s PROPSYS.DLL
    regsvr32 /s QAgent.DLL
    regsvr32 /s qagentrt.DLL
    regsvr32 /s QUtil.DLL
    regsvr32 /s raschap.DLL
    regsvr32 /s RASQEC.DLL
    regsvr32 /s rastls.DLL
    regsvr32 /s repdrvfs.DLL
    regsvr32 /s RPCRT4.DLL
    regsvr32 /s rsaenh.DLL
    regsvr32 /s SHELL32.DLL
    regsvr32 /s shsvcs.DLL
    regsvr32 /s /i swprv.DLL
    regsvr32 /s tschannel.DLL
    regsvr32 /s USERENV.DLL
    regsvr32 /s vss_ps.DLL
    regsvr32 /s wbemcons.DLL
    regsvr32 /s wbemcore.DLL
    regsvr32 /s wbemess.DLL
    regsvr32 /s wbemsvc.DLL
    regsvr32 /s WINHTTP.DLL
    regsvr32 /s WINTRUST.DLL
    regsvr32 /s wmiprvsd.DLL
    regsvr32 /s wmisvc.DLL
    regsvr32 /s wmiutils.DLL
    regsvr32 /s wuaueng.DLL
    sfc /SCANFILE=%windir%\system32\catsrv.DLL
    sfc /SCANFILE=%windir%\system32\catsrvut.DLL
    sfc /SCANFILE=%windir%\system32\CLBCatQ.DLL
    net start "COM+ Event System"

  4. Reboot the computer.

 

VSS Troubleshooting Tip #3

Uninstall all backup software on your computer, including Windows Backup if it's installed.  After all other backup tools have been uninstalled, open the Registry Editor (regedit) as administrator and check the following branch:

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\services\VSS\Providers  

Underneath that key you should only find Microsoft Software Shadow Copy Provider 1.0 and no other VSS writer. If you do find another, it may be a residue registry entry of a previous backup software installation. You can save the entry by exporting the entire registry to a file (right click and select Export) and then it's safe to delete the entire branch entry underneath HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\services\VSS\Provider. Then reboot and try again running vssadmin list writers to confirm the problem has been resolved.

 

VSS Troubleshooting Tip #4

On some systems, the command vssadmin delete shadows isn't available. In Windows XP that's okay because VSS snapshots can't be persistent on XP (a reboot will get rid off them); however, on Vista you need to delete old shadows using:

vssadmin Resize ShadowStorage /For=C: /On=C: /MaxSize=300MB

300MB is usually the smallest amount you can specify and will effectively delete any existing VSS snapshots on your system.

If you don't get any VSS writer errors when using vssadmin list writers but the system isn't able to create a new VSS snapshot (and you have deleted all existing snapshots), then you may have to actually increase the max shadow storage size on your system. Use the previous command with a greater number, such as 10GB:

vssadmin Resize ShadowStorage /For=C: /On=C: /MaxSize=10GB

Note that it is also possible to allocate shadow copy storage space on a different drive, as along as it's local:

vssadmin Resize ShadowStorage /For=C: /On=X: /MaxSize=200GB

 

VSS Troubleshooting Tip #5

Open vssadmin from the command line (run cmd as administrator).

Enter vssadmin delete shadows /all to clean up any dead VSS snapshots. Some defect systems accumulate hundreds of VSS snapshots that persist in the system and cause Windows to become unresponsive.

Enter vssadmin list writers and check for errors. If you receive any errors for one VSS writer, you may need to fix that particular VSS writer. It is common to receive writer errors caused by Microsoft's Virtual Server 2005 VSS writer.

If you see a VSS writer error, try the following:

 

Restart the services:

  • COM System Application Service
  • Distributed Transaction Coordinator Service
  • Volume Shadow Copy Service

 

and also restart the affected VSS writer service, for example Virtual Server 2005 VSS writer or Hyper-V VSS writer.

Check the Event Viewer for any additional error information logged by that VSS writer.

Run again vssadmin list writers to check if the above resolved the problem. If it didn't follow with the next strategy below.

 

VSS Troubleshooting Tip #6

If the PC or server you are using is a virtual machine host, you need to install the latest VMware Tools (for VMware), Virtual Machine Additions (Virtual Server), on each virtual machine.

 

VSS Troubleshooting Tip #7

Your computer may have a corrupt COM subscription information. Open the registry editor (regedit) and navigate to:

HKLM\Software\Microsoft\EventSystem\{26c409cc-ae86-11d1-b616-00805fc79216}

Then delete the Subscriptions key and reboot the machine.

A subsequent call in the command prompt should show no more errors: vssadmin list writers

This VSS repair strategy appears to work well when the System Writer is reporting an error. The Event Viewer may be reporting this or a similar error:

Writer Class Id: {e8132975-6f93-4464-a53e-1050253ae220}
Writer Name: System Writer
Writer Instance ID: {34162f4c-59ff-468e-848d-cb4b3d8dd7dc}

 

VSS Troubleshooting Tip #8

Install the latest Service Packs and Updates through Windows Update.

Check Microsoft's Support for hot fixes and other updates to repair VSS.

 

If the following has not helped to resolve your VSS errors, we recommend you contact Microsoft Support for further assistance.

 

 

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