Problem
- backup completed successfully, but this warning message is logged: -
WARNING: Unable to find the archive index. Assuming archive index is the same as the file index.
- Backup image is created, but "verify" or recovery tasks ran from Kaseya will fail with error "failed to find backup URI by the backup's ID"
- Backup image can be successfully "validated", or recovered from, using Acronis Management Console
- if the "synthetic full" feature is enabled, the next synthetic full backup will fail
Cause
After each backup Kaseya runs an Acronis command to query the backup set, and populates the Kaseya database with the ID of the backup. The "unable to find the archive index" warning means this process failed. It can be caused by: -
- there was a problem with read access to the image location at the time the backup completed (for example, a network error) - in this case, the problem may be intermittent or isolated to a single backup job
- a corrupt backup set (for example, images created by earlier backups in the same set have been deleted) - in this case, the problem will persist until a new full backup is created
Resolution
1) if the error is only present on the current backup set, force a full backup using these steps: -
a. go to Backup > Image Password page
b. re-enter the image password for the agent in question, and reapply using the . This will force the next backup to be a non-synthetic full backup. (NB - there is no need to change the password, simply reapplying the same password again is sufficient)
If the issue persists after full backup: -
2) Ensure that the credential user set on the Agent > Set Credential page has full (read/write/modify) permissions to backup image location
3) check for any changes to the image location
4) test backing up to a different image location (this will isolate whether problem is with image location or the machine being backed up)
Applies To
Kaseya VSA (Backup module) - v6.5-R9.5