Backup client install fails - incomplete installer download

PROBLEM

When installing Backup client (Acronis) to an agent: -

- Backup > Install/Remove page prompts to reboot the agent

- after reboot, status changes to "verify failed"

- agent procedure log has the error shown below

 

12:47:49 pm 15-Dec-14 Finish Backup Installation *System* Script Summary: Failed THEN in step 4

12:47:49 pm 15-Dec-14 Finish Backup Installation *System* FAILED in processing THEN step 4, Write File, with error Invalid Parameter, Source = C:\Kaseya\WebPages\ManagedFiles\VSAHiddenFiles\BUDR\AcronisAgentCore.msi, Destination = c:\kworking2\AcronisAgentCore.msi

 

CAUSE

  • The problem has been documented.

 

SOLUTION

A patch has been released for VSA R9, and is planned for R8.

VSA R9

A fix is included in patch release 9.0.0.5: -

Fixed an issue that caused the installation of the Backup client to an endpoint to fail. (IP-520/EDGE-312)

VSA R8

A fix is included in patch release 8.0.0.15: -

Fixed an issue that caused the installation of the Backup client on endpoints to fail. (IP-557/EDGE-312)

VSA R7

Server must be updated to R8 or R9.

This workaround can be used to deploy Backup client to affected agents: -

1) on the Kaseya server, create a folder called "BUDR" under C:\Kaseya\WebPages\ManagedFiles\VSASharedFiles

2) copy these files to the new folder from C:\Kaseya\WebPages\ManagedFiles\VSAHiddenFiles\BUDR

- AcronisAgentCore.msi

- AcronisAgentWindows.msi

- AcronisAgentWindows.mst

- AcronisCommandLineTool.msi

- AcronisManagementConsole.msi

3) in VSA, go to Agent Procedures > Schedule/Create, select a folder and click the "Import Folder/Procedure" button

4) select the Procedure Deploy backup client.xml file attached below

5) schedule the imported procedure on the affected agent(s) - it will download the required files using a different mechanism to the built-in procedure, and run the install commands

6) when the custom procedure finishes, reboot the agent machine, then go to Backup > Install/Remove page and use "verify install" button to bring it under management

 

 

 

APPLIES TO

Kaseya VSA - v7.0, R8

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