Problem
Offsite replication has too much data remaining to upload, and there is insufficient bandwidth available to complete replication in reasonable timeframe.
Cause
This situation may arise for one of the following reasons: -
- synthetic full backups are enabled, but there is insufficient bandwidth available to replicate the initial full backup image
- replication of a full backup image is required because an offsite synthetic full backup has failed, or offsite incremental backup processing failed
- replication fell behind due to an extended network outage or other problem
Resolution
The following steps may be used to manually “seed” replication data from a specific local server: -
1) suspend replication from the local server using Schedule Transfer page (set to “Off”)
2) copy all files with data remaining to upload from the local server “directory path” (as configured on Local Servers page) to a removable drive, maintaining the directory structure
Important: -
- do not re-copy files which have already been replicated, as this may corrupt the offsite backup sets
- do not copy full images created from synthetic full backups, unless an offsite synthetic full backup has failed and Backup Logs indicate that file needs to be replicated
- Local Server status section of Backup Status page shows which files have data remaining to upload - only these files should be copied
3) take the removable drive to the offsite location and copy the files to the appropriate location.
Please note the directory structure: -
Local server - [LocalServerDir]\[GUID of backup agent]
Example - E:\backups\123456789
(where 123456789 is the agent GUID of a backup agent
Offsite server - [OffsiteServerDir\[GUID of local server]\[GUID of backup agent]
Example - F:\offsite\987654321\123456789
(where 987654321 is the agent GUID of the local server)
In this case, all files requiring replication from E:\backups on the local server (there may be several backup agent GUIDs) need to be copied to F:\offsite\987654321\ on the offsite server. The folder structure below that will be the same.
4) go the Offsite Servers page and restart replication on the offsite server that the files were copied to, using the green "swirl" icon next to the agent name (this is to clear any file locks which may interfere with offsite backup processing)
5) start replication again from the local server using Schedule Transfer (set back to the usual schedule)
Applies to
Kaseya VSA (Backup module) - all versions