Critical backup component is missing and failed to download

Problem

I am getting below error in the Backup > Install/Remove page.

"Critical backup component is missing and failed to download"

2015-03-02_14_38_58-Kaseya_-_Agent.png

 

Cause

Acronis install files are not present on the Kaseya server (see below). Usually they are automatically downloaded soon after installing Backup module. The download may fail because of environmental issues, for example: -

  • Kaseya server does not have access to the internet, or proxy settings are configured incorrectly
  • AV software or firewall blocks download

2015-03-02_15_00_45-Kaseya_-_Agent.png

Solution

Download the missing files and copy them again into the correct directory: -

1) download files from below URLs :

http://download.kaseya.com/components/backup/v11/AcronisAgentCore.msi 
http://download.kaseya.com/components/backup/v11/AcronisAgentWindows.msi 
http://download.kaseya.com/components/backup/v11/AcronisCommandLineTool.msi

(if the files cannot be downloaded from the Kaseya server itself, use another computer)

2) Copy the above files to the following directory on your server :

\Kaseya\WebPages\ManagedFiles\VSAHiddenFiles\BUDR\

 

Applies to

Kaseya VSA - v6.5 and later

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