Unable to run command line utilities requiring user interaction from KLC Commands page

Problem: 

When running a command requiring user interaction from the Kaseya Live Connect (KLC) Commands page, the prompts are not displayed and the command behaves as if no data was entered.

The below example is from "net user" password change command when running directly from Windows command shell (cmd.exe):

2018-03-22_1454.png

When running the same command from the KLC > Commands page:

2018-03-22_1455.png

 

Cause

The KLC > Commands page does not support "interactive" command line utilities which involve user prompting. KLC sends commands from the browser to the agent and then returns the output. If the command involves a prompt, there is no actual "real" user to answer the prompt so it will behave as if nothing had been entered, sending this output back to the browser.

 

Resolution

None available. This is by design.

 

Applies to:

Kaseya VSA (all versions)

Have more questions?

Contact us

Was this article helpful?
0 out of 0 found this helpful

Provide feedback for the Documentation team!

Browse this section