Problem
- when assigning a KSBR profile to an agent (using Assign by Profile or Assign by Machine page), the profile will show as assigned for a short time, then the check mark in "Assigned" column disappears
- Assignment History tab on Backup History page has this error - "The credentials did not have permissions to the image location".
Cause
The "network credential" configured in the profile cannot access a LAN share configured as the backup destination
Resolution
Ensure that the network credentials you set while creating/editing the profile have permissions to read and write to the specified backup destination. You can change the profile's network credentials from System Backup and Recovery > Profiles > Manage page. From there, edit the profile and follow the steps until you reach the Configure Destination step.
- the Shadowprotect Backup Service credential is, by default, a local user created automatically by the Shadowprotect installation process. Usually it can only access LAN shares that are not password protected.
- if Use set credentials for this agent is selected, the credentials configured under Agent > Set Credential page will be used. The "test" button on that page will check that the credentials are valid, but does not test access to the backup destination.
To validate that the selected credentials have sufficient permissions, test as follows: -
1) log onto Windows with the selected credentials (if it is already logged in, log out and in again, in case any other credentials have been cached)
2) attempt to access the configured LAN share manually, and try to create a file. If you see a Windows error message, or you are prompted for additional credentials, the account does not have permissions to the share
Applies to
Kaseya VSA (System Backup and Restore) - all versions