KDB - backup logs exception "connection to the server could not be established"

Problem

  • backup logs status "completed with exceptions"
  • exception log includes this entry - "connection to the server could not be established"
  • the backup did not run to completion (clicking on the "completed with exceptions" hyper-link in Result column shows that fewer files were processed than the number showing in the Files column)

 

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Cause

This exception is logged when the backup agent loses network connectivity to the storage server.

 

Solution

If the exception occurs persistently, perform the following steps to isolate the problem: -

 

1) check the logs from other backup agents assigned to the same storage server with similar size backups: -

- if the exceptions are isolated to a specific agent, or several agents in the same network location, the problem is likely to be related to the agent side network

- if the exceptions occur on agents in multiple network locations, the problem is likely to be related to the storage server network location

 

2) test backup from at least one affected agent to a storage server located on the same internal network

- if there is not already a "local" storage server configured, create one using Data Backup > Private Storage function

- ensure that "primary address" is the local IP address

- after reassigning backup agent to a "new" storage server, it will create new backup of all selected files. When assigned back to the original storage server, backups will continue from where it had left off.

 

3) if exceptions do not occur in "local" backup, monitor the relevant network links to ensure there is a stable connection

 

Applies to

Kaseya VSA (Data Backup module) - all versions

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