Problem
Kaseya Data Backup (KDB) stores success and exception logs for each backup in the following location on the Kaseya server: -
- c:\Kaseya\UserProfiles\<agentGUID>\Audit\KOB\kob_success_<timestamp>.log
- c:\Kaseya\UserProfiles\<agentGUID>\Audit\KOB\kob_exception_<timestamp>.log
(where <agentGUID> is the GUID of the agent that ran the backup)
These logs are causing the Kaseya installation disk to fill up.
Cause
The success log contains details of every file that was processed by the Backup. The exception log contains details of each file that could not be backed up.
They can be accessed from hyper-links in "result" and "exception count" columns on Data Backup > Backup > Logs page.
By default, these logs are retained for 90 days.
Solution
There is a setting in the database where log retention can be configured as follows: -
- success logs are retained only for the last 3 successful backups on each agent
- exception logs are retained only for the last 3 backups with exceptions on each agent
To apply this setting: -
1) open SQL Server Management Studio (SSMS) on the Kaseya Database server
2) run this query: -
USE ksubscribers
UPDATE kserverParams
SET paramValue = 'True'
WHERE paramName = 'CleanAuditLogs'
3) older logs will be automatically deleted the next time a KDB backup runs on each agent (if necessary, they can be deleted manually to reclaim space in emergency)
Please note, once the logs have been deleted, only the summary of those jobs will be available from Data Backup > Backup > Logs page.
Applies to
Kaseya VSA (Data Backup module) - all versions