Problem
Data Backup (KDB) logs this error when trying to back up an agent: -
Error! BackupFailedToStart: There was an error with the agent database.
Cause
KDB backup database on the agent machine is corrupt.
Resolution
1) on the agent machine, locate the Kaseya Agent installation directory
- by default, C:\Program Files (x86)\Kaseya\[serverID] on 64-bit OS or C:\Program Files\Kaseya\[serverID] on 32-bit
- [serverID] is a unique ID, for example KSAASC1234567891234
2) rename the "KOBdb" sub-directory
3) start a new backup - the database will be recovered from the last completed backup on the storage server
Applies to
Kaseya VSA (Data Backup module) - all versions