Problem
Negative license count in KSDU > Licensing page
Cause
Normally this issue occurs when profiles assigned to the machines are more than available licenses.
When using Policy Management to assign KSDU profiles and scheduling scans, make sure you have enough licenses to assign those profiles. If the Policy applies KSDU profiles to more machines than the available licenses then license left count will show as negative.
Resolution
Check if the policy is deploying KSDU profiles to the right machines. Remove those extra machines from the profiles to bring the license count back to normal.
Sometimes the sync between frontend and backend is required to resolve the KSDU incorrect license count issue. This can be done by running a 'Reapply Schema' from System > Configure page.
If the issue still persists then please create a support ticket for further assistance.
Details on KSDU Licensing
Once a KSDU license is used on a machine, it is locked on that machine until 30 days from the day it was used. After the 30 days, if the license was removed or the agent was removed, then the license gets freed up. Please see this below information:
For any particular machine, a KSDU license is consumed under any of the following conditions:
- a KSDU scan is performed
- a deployment is performed
- a machine is assigned to a profile, or remains assigned to a profile.
A machine can only consume one KSDU license.
If there are 31 days of inactivity (no scans, no deployments, and unassigned from all profiles), the KSDU license goes back into the pool of available KSDU licenses.
Applies to
All VSA versions.