Traverse: Maximum query thread limit reached

PROBLEM:

Test Status Message: Maximum query thread limit reached

 

CAUSE:

  • If your wmi test change from OK/WARNING/CRITICAL to "UNKNOWN" state

 

e.g from this image (click: Status > Devices):

Image2.jpg

 

To unknown status: 

Image3.jpg

 

And if you review the error you see: "Maximum query thread limit reached" (https://kaseya.zendesk.com/entries/103521236-How-to-review-a-warning-critical-unknown-error-in-the-web-interface)

Image_1.jpg


In correlation you will see in  <traverse_home>/logs/nvwmiqd.log

(WARN) [thread-5016] Approaching maximum queue size of 1500; Current queue size is 1495
(WARN) [thread-5016] Approaching maximum queue size of 1500; Current queue size is 1497
(ERROR) [thread-5016] Maximum queue size of 1500 reached; Subsequent queries will be discarded


(ERROR) [thread-109] \\10.10.10.6\\\root\cimv2?admin; class="Win32_PerfRawData_DHCPServer_DHCPServer"; property=OffersPersec; @; queryId=160; Unable to connect to server: Connection failed
(ERROR) [thread-142] \\10.10.10.135\\\root\cimv2?admin; class="Win32_Service"; property=Started; Name="McAfeeEngineService"; queryId=1279; Unable to connect to server: Connection failed
(ERROR) [thread-149] \\10.27.10.6\\\root\cimv2?admin; class="Win32_PerfRawData_NTDS_NTDS"; property=LDAPActiveThreads; @; queryId=1291; Unable to connect to server: Connection failed
(ERROR) [thread-216] \\10.10.14.16\\\root\cimv2?admin; class="Win32_PerfRawData_DNS_DNS"; property=UDPResponseSent; @; queryId=24696; Unable to connect to server: Connection failed


This 4 ip's are monitored servers with wmi test configured.

RESOLUTION:

  • Troubleshoot steps:


1. suspend all WMI tests in Traverse for these IP addresses
2. Review WMI configuration on this servers:

- validate with wbemtest from the DGE/DGEX to the remote system
- stop and restart (in appropriate maintenance windows) the Windows Management Instrumentation service and/or the Remote Registry services on the target server

3. Once you have confirmed that WMI communication between DGE/DGEX is working properly, restart Traverse WMI Daemon
4. Resume all suspended WMI tests

 

APPLIES TO:

All versions of Traverse

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