Unable to discover SNMP tests

PROBLEM:

Unable to discover any SNMP tests when there should. This is assuming it is known the device supports at least RFC system level metrics and any missing SNMP tests are not due to unsupported SNMP tests (i.e. a new device signature is needed).

When an SNMP discovery is initiated within Traverse, it must first be determined whether or not the device supports SNMP. To determine this, Traverse assumes the device adheres to the standard that it reports sysDescr and attempts to query (snmpget) on sysDescr (.1.3.6.1.2.1.1.1.0). If the device does not report any information for sysDescr, it is determined the device does not support SNMP and discovery does not proceed for this device.

 

CAUSE:

The following is to be performed on the DGE (or DGEx) server directly monitoring the affected device

 
For SNMP v2c: snmpget -Oefqnt -v 2c -c XYZ n.n.n.n .1.3.6.1.2.1.1.1.0 where XYZ is the community string and n.n.n.n is the IP address of the device For SNMP v3: snmpget -Oefqnt -v3 -l <noAuthNoPriv|authNoPriv|authPriv> -u <username> [-a <MD5|SHA>] [-A <authphrase>] [-x DES] [-X <privaphrase>] n.n.n.n .1.3.6.1.2.1.1.1.0 where n.n.n.n is the IP address of the device For SNMP v1: snmpget -Oefqnt -v 1 -c XYZ n.n.n.n .1.3.6.1.2.1.1.1.0
where XYZ is the community string and n.n.n.n is the IP address of the device

 

If the device's SNMP agent responds with "No Such Object available on this agent at this OID" or empty/null value "", it is expected that the current SNMP discovery process will fail against this device.

 

RESOLUTION and WORKAROUND: 

Resolution

Configuring the device to report on sysDescr (.1.3.6.1.2.1.1.1.0) will allow SNMP discovery to proceed

Workaround

Important notes before deploying the workaround

  • This workaround is only applicable if the device reports at least one of the system OIDs .1.3.6.1.2.1.1.1.0 - .1.3.6.1.2.1.1.8.0

  • After discovery and provisioning of selected tests has been completed, it is recommended to put back the original probeSnmpTests.pl script. Due to the modified script checking each system OID, this can result in increased discovery times against devices that actually do not report SNMP. Effectively, this can result up to a total increase of 45 seconds per device that times out for SNMP (does not report any of the system level OIDs).

It has been found that some devices to not adhere to RFC standard and may not report sysDescr, sysUptime, or sysObjectID. This results in the problem with discovering SNMP tests. As a workaround, a modified SNMP discovery script is attached that attempts to query each object within the system table (.1.3.6.1.2.1.1.1.0 - .1.3.6.1.2.1.1.8.0) to verify SNMP support.

 

  1. On the DGE (or DGEx) server directly monitoring the affected device, backup the following file:
    <TRAVERSE_HOME>/utils/probeSnmpTests.pl
  2. Download the attached file and replace the previous file
  3. Attempt an SNMP discovery against the device(s)
  4. The modified script should allow the SNMP discovery to verify that the device supports SNMP and proceed to discover supported SNMP tests
  5. See important note above regarding putting back original probeSnmpTests.pl

 

APPLIES TO:

All versions of Traverse 

 

REFERENCE:

None

 

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