Troubleshooting: Access to the path is denied

Problem

When navigating to a page in the VSA for Kaseya, you get the following Server Error in '/' Application page.

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Cause

The permissions of the requested directory or file changed and is no longer accessible by IIS.

Solution

Navigate to the directory or file described in error message on the KServer. If the file is within the Kaseya installation folder, navigate to the top Kaseya folder. Right click on the folder and select Properties, then click on the Security tab. Add the IUSR and grant full control.

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Afterwards, restart all of the Kaseya services as described in this KB article https://kaseya.zendesk.com/entries/104727073-How-To-Restart-Kaseya.

Applicable To

All On-Premise installations of Kaseya

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