Issue:
When using auto-deployment to push agents out to discovered machines on a network, the custom agent icons are not deployed at the time of the agent install
Cause:
The agent installer KcsSetup.exe contains the custom agent icons. These are contained in the agent install package and are installed on the machine when the agent installer runs. They are stored in c:\program files\kaseya\xxxxxxxx\custom.
When the agent starts, it looks in the custom folder and uses the icons in that folder.
The auto deployment has an issue which causes the files to be delivered to c:\program files\kaseya\xxxxxxxx\, rather than the custom sub-folder.
Solution:
Once the agents have been deployed, perform the following steps to push the branded/custom icons to the machine.
1. log in to kaseya
2. go to the agent tab -> update agent page
3. select the machines that you want to change
4. select the "Force agent update" checkbox at the top of the page
5. click update
This will push the custom agent icons to the machines in the correct location.