PROBLEM
The windows user directory (c:\users) is populated with one or more TEMP folders.
This is known to affect Windows from Vista onwards and is not a Kaseya generated problem - this can occur on computers that do not have Kaseya agents installed.
CAUSE
There are several reasons that this can happen, however the most common cause is that the user's profile has been deleted from the disk, but the Windows account still remains on the system.
When a user logs in, Windows tries to load the user's profile. This includes the user's registry hives (HKCU) and system settings.
The user's profile on disk is linked to the user account in windows.
If Windows is not able to load the profile, it will create a temporary profile in c\users.
This is repeated until the original problem is resolved.
SOLUTION / WORKAROUND
Microsoft has a KB article that cover this issue and they provide steps to resolve this problem.
A temporary profile is loaded after you log on to a Windows Vista-based system
https://support.microsoft.com/en-us/kb/947242
If this is affecting the account that you are using for the Kaseya agent, and not an acount that a Human logs in with, the quickest solution is to remove the Windows account, delete the profile from disk and recreate the account.
Becuase the Kaseya agent doesn't need to store anything in the profile, deleting and recreating will not result in the loss of any useful data.
If this is only affecting a small number of machines, this can be done manually. However, if you are seeing this on a larger number of machines, you can do this through an agent procedure.
The Kaseya Agent procedures have two useful functions:
deleteUser()
createLocalUser()
These can be used to delete the windows User account and recreate it.
Once the problem account has been deleted and recreated, run a KSDU scan to confirm that the problem is resolved.
ADDITIONAL INFORMATION
We advise that you use a dedicated account for the Kaseya Agent to run its procedures as, rather than specifying a user account that someone else may be using.
If Jenny is a user on the system, who is logged in, and the Kaseya Agent (or any other service) tries to execute commands as Jenny, you can encounter locking issues. The Human Jenny user will already have her profile loaded, and so when another process tries to log in, Windows is unable to load the profile as it is already locked by the existing logged in user.