Unable to control KAV via Remote Control

Problem:  Unable to control KAV via Remote Control in Version 7.

Causes:  
 
By design, this is a security feature provided by Kaspersky that disabled remote protocols from accessing the Kaspersky GUI. Self-Defense is the component that protects Kaspersky Endpoint Security 10 for Windows against malware attempting to block the application or remove it from host. 

Self-Defense helps to avoid the following actions of malicious programs:
  • Modification or removal of application files, including program files, antivirus databases, quarantined files, trace files
  • Modification or removal of Kaspersky Endpoint Security 10 for Windows system registry keys
  • Termination of application processes
  • It basically protects the software itself from outside intrusion (which unfortunately includes remote control outside of RDP)
 
Resolution:
 
This has been fixed in Version R8 to allow control of UI via remote control. Keep in mind this only applies to KAV Classic since the exclusion and trusted apps are added in the Global Exclusions per installation.
 
As a workaround for v7 and v6.5, you can disable self-defense via the kav profile settings.  (You must reapply the profile after making changes)
 
 
If the issue persists, please contact Kaseya Support.

Have more questions?

Contact us

Was this article helpful?
0 out of 0 found this helpful

Provide feedback for the Documentation team!

Browse this section