KAV - Kaspersky definition files failing to update

Problem

Kaspersky virus definitions are failing to update on KAV endpoints.

Please note - this article does NOT apply to situations where Kaspersky is up-to-date but Kaseya console shows it is out-of-date.

 

Cause

- Kaspersky has a configuration available in their API where updates will not run unless screen saver is activated. This option is not exposed in Kaspersky UI and is not available in KAV profile, but default was recently changed to activate it unless explicitly deactivated when applying profile.

- this affects both "automatic" and "scheduled" update configurations on all Kaspersky client versions

- Kaseya released a patch (v9.2.0.13) to deactivate this configuration when applying the KAV profile. This will resolve the issue in most cases, but we have seen some cases where the configuration is not successfully changed. This is currently under investigation by Kaseya and Kaspersky engineers.

 

Solution

- ensure that VSA server is updated to patch release 9.2.0.13 or higher

- once patch is applied, profile needs to be reapplied to all affected agents

- if Kaspersky still fails to update, please open a support ticket with details, including reference to this KB article and Kaspersky Update report from at least one affected agent

update_report.png

 

Ref: #122135 / PROTECT-648

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