Problem:
Unable to upgrade Windows 8.1 / Windows Server 2012 R2 if Kaspersky Endpoint Security is installed.
Cause:
The following is a known limitation of Kaspersky
- If Kaspersky is installed on Windows 8 or Server 2012 and would like to upgrade to Windows 8.1 or Server 2012 R2, Kaspersky must be uninstalled first.
- If Kaspersky is not uninstalled then the Windows upgrade may fail with the following Windows error code 0x80070005 (Access Denied).
- If Kaspersky is disabled then the Windows upgrade may complete but it will not be possible to re-enable Kaspersky after the upgrade as it will be corrupted.
Solution:
The workaround is to uninstall Kaspersky and re-install after upgrading Windows
More information can be found in the Kaspersky article below.
Applies to Kaspersky version 10.2.1.23