SYMPTOMS
When trying to connect to a Windows computer using Kaseya Remote Control (KRC) with a private session or using 1-Click Access, the remote control viewer displays the below message.
Old KRC
CAUSE
The above message will be displayed if:
- The Operating System of the agent machine does not support the 1-Click Access or Private Session feature. Please refer to online help (http://help.kaseya.com/WebHelp/EN/VSA/9040000/reqs/index.asp#18007.htm) for details. Please note that Windows XP and Windows Server 2003 are not supported.
- Remote desktop policy on the agent machine prohibits remote connections or requires Windows native RDC client with Network Level Authentication.
- There is a conflicting group policy setting not allowing the private remote session to authenticate over RDP
SOLUTION
Letting Private session set RDP connections and NLA setting
- When you open a private session and RDP and NLA settings are incorrect, the KLC app will prompt you with the following:
- Choose whichever option you want, this should set the RDP and NLA settings for you without having to do it manually.
Setting RDP connections and NLA manually
-
If the agent machine has supported OS, go to Control Panel > System and Security > System > Remote Settings
-
configure as shown below
Conflicting Group Policy
If you use group policies on your devices there may be conflicting policies that will not allow Private or 1 click access sessions to work properly. Be sure to review the following group policy
- Run gpedit.msc, next expand Computer Configuration >> Administrative Templates >> Windows Components >> Remote Desktop Services >> Remote Desktop Session Host >> Security
- Next, select the policy for "Require use of specific security layer for remote (RDP) connections"
- Ensure that the policy is set to "Not Configured" or if it needs to be enabled set the security layer to "Negotiate" and hit apply
APPLIES TO
Kaseya VSA