PROBLEM
There are many situations where you may wish to execute an Agent Procedure step as the "User" account instead of the default option of the "System" account.
In some of the Agent Procedure steps, you have the option to execute the step using the "User" account instead of the "System" account.
However, despite making this change the step still executes under the "System" account and not the "Users" account.
CAUSE
For Kaseya to be able to run an Agent Procedure as the logged in User account, it requires the "KaUsrTsk.exe" process to be running for this User.
RESOLUTION
Ensure that "KaUsrTsk.exe" is running for the intended User account.
APPLIES TO
6.3,6.5,7,8,+