Agent Procedures taking longer to execute

PROBLEM

My procedures take a long time to execute and don't complete till a few hours later.

Kaseya UI regularly hangs and I am unable to perform any tasks.

CAUSE

There are 3rd party applications that are backing up the Kaseya database and the database IO is regularly getting frozen.

3-2-2015_8-19-25_AM.jpg

When the database IO is frozen, no SQL tasks can be performed against the database and this regularly happens when a database backup is performed.

When 3rd party applications such as Acronis and StorageCraft perform backups, the database IO is frozen so that the application can take a full snapshot of the file. Only once the backup of the file is complete, will the IO be resumed. Depending on the size of the database, the IO can be frozen for 2 minutes to 2 hours.

Every minute that the database IO is frozen is one minute where no procedures are executing. When the IO is resumes, all those pending procedures will begin to execute. All other procedures then begin to line up behind these pending procedure and may not execute for hours at a time.

SOLUTION

The solution is to perform the backups only at night or on the weekends when the system is not being used by any one and hindering work performance.

APPLIES TO

All VSA versions

Have more questions?

Contact us

Was this article helpful?
0 out of 0 found this helpful

Provide feedback for the Documentation team!

Browse this section