SUMMARY
Cold copy times may be unusually long due to unnecessary processes consuming appliance resources.
ISSUE
Cold copy times may be unusually long due to unnecessary bpserverd processes consuming appliance CPU resources.
RESOLUTION
To determine if you have this condition, you may check bpserver log history in /usr/bp./logs.dir.
Confirming this issue can be done if you see multiple log parts for a bpserverd process being created in quick succession, 0-1 seconds apart. Here's an example:
ls -rlast /usr/bp/logs.dir/bpserver-*_*.log -rw-rw-r-- 1 root loggers 10485854 Jul 24 11:44 bpserver-9_2.log -rw-rw-r-- 1 root loggers 10485847 Jul 24 11:44 bpserver-2_2.log -rw-rw-r-- 1 root loggers 10485854 Jul 24 11:44 bpserver-9_1.log -rw-rw-r-- 1 root loggers 10485847 Jul 24 11:44 bpserver-2_1.log -rw-rw-r-- 1 root loggers 7392888 Jul 24 11:44 bpserver-9.log -rw-rw-r-- 1 root loggers 8993669 Jul 24 11:44 bpserver-2.log
Further confirmation would require looking at the contents of these logs. If the value "SR: timed out [1]" is repeating through the log with high frequency, then you are impacted by this issue. here's an example:
cat /usr/bp/logs.dir/bpserver-9_2.log | grep "SR: timed out [1]" 2017-07-24 11:38:18.115 -0500 : [LOG1] SR: timed out [1] 2017-07-24 11:38:18.115 -0500 : [LOG1] SR: timed out [1] 2017-07-24 11:38:18.115 -0500 : [LOG1] SR: timed out [1] 2017-07-24 11:38:18.115 -0500 : [LOG1] SR: timed out [1] 2017-07-24 11:38:18.115 -0500 : [LOG1] SR: timed out [1] 2017-07-24 11:38:18.115 -0500 : [LOG1] SR: timed out [1]
To resolve this issue, upgrade your appliance to version 10.1.
CAUSE
Several different processes could result in a competing condition lending a bpserverd process to continuously poll for status decreasing CPU availability. This condition is rare but when encountered during a cold copy can impact backup or cold copy performance.
The resolution involves a combination of kernel update to linux as well as several Unitrends code adjustments.