'No S3QL filesystem was found' error when adding cloud storage

SUMMARY

If this error occurs with cloudadm 1.67, update to cloudadm 1.69 or later.

ISSUE

Symptoms
See this error message when trying to connect to CloudHook storage:

cmc_nas execution failed.
No S3QL filesystem was found at
s3://unitrends-free-aws/offsite-backups/
ERROR: Failed to mount directory unitrends-free-aws/offsite-backups/ on /backups/Cloud_Storage.
You can verify the version of cloudadm by running this command from a PuTTY/ssh command line:
​cloudadm status
cloudadm version 1.74
CLOUD TYPE      | STORAGE       |ONLINE| MAX_GB |USED_GB
...





 

RESOLUTION

When trying to add or connect to CloudHook storage, sometimes an earlier error may have been masked and the S3QL cloud filesystem did not get created.  The resolution is to upgrade the cloudadm binary to version 1.69 or later.

Steps to apply the hotfix from a PuTTY/ssh command line:

  1. wget ftp://ftp.unitrends.com/support/Hotfixes/cloudadmc6-174
  2. chmod +x cloudadmc6-174
  3. cp /usr/bp/bin/cloudadm /usr/bp/bin/cloudadm-orig
  4. cp -f cloudadmc6-174 /usr/bp/bin/cloudadm

CAUSE

If you are receiving this error message and already have cloudadm 1.69 or later, then please examine the /usr/bp/logs.dir/cloudadm.log for any error messages preceding the 'No S3QL filesystem' error to determine the cause.

Have more questions?

Contact us

Was this article helpful?
0 out of 0 found this helpful

Provide feedback for the Documentation team!

Browse this section