VMware Instant Recovery Fails with "InvalidDeviceSpec" Error

SUMMARY

VMware Instant Recovery Fails with "InvalidDeviceSpec" Error

ISSUE

Purpose

Steps for resolution when “InvalidDeviceSpec” error is received when performing VMware Instant Recovery (VMIR) of a virtual machine (VM).

 

Description

This error occurs when the VM that gets created for VMIR is not able to access it’s disks that are on the Unitrends appliance. Due to this, the creation of the VM fails with an error like –

  Instant recovery failed: Failed to perform instant recovery: Error creating VM – InvalidDeviceSpec (Invalid device configuration): $VAR1 = ‘

 

Cause

 If the VM that gets created for VMIR can’t access it’s disks that are on the Unitrends appliance, then, the creation of the VM fails.

 

Resolution

 Below are the steps that will help tear down the VMIR session and start it again –

  1. Using the vSphere Client, access the vCenter/ESX server on which the VMIR is being performed. Click on the ESX server.
  2. Go to “Configuration” tab.
  3. Under “Hardware”, click on “Storage”.
  4. Various datastores attached to that ESX server are seen. There will be a datastore named “Unitrends_Instant_Recovery_xxx” and it would be greyed out.
  5. Right click that datastore and select “Unmount”
  6. On the Unitrends interface, go to “Settings > Instant Recovery > VMware” and click on the VMIR session that failed with the “InvalidDeviceSpec” error. Click “Tear Down”.
  7. Perform the VMIR again for that VM.

 

Third-Party Sources

N/A

Have more questions?

Contact us

Was this article helpful?
0 out of 0 found this helpful

Provide feedback for the Documentation team!

Browse this section