PROBLEM
Upon attempts to perform a restore from a NAS or Linux to a Windows fail with the error "Server cancelled task".
Review of the Windows application event log reveals that the Unitrends agent is crashing.
The error details the faulting module name is ntdll.dll as seen below:
The bottom of the WBPS log reports a failure to create the required paths to recover to files to without any log closure:
BP: Cannot create \\?\D:\NASRestore\mnt\nas\AS-NAS_HR\AmeriFlex after retry #3
01/31/25 18:35:30 : 21256::extract_normal_file::1568 failure.
01/31/25 18:35:30 : extract_normal_file::mnt\nas\AS-NAS_HR\AmeriFlex Create file failed.
<NotBackedUp> mnt\nas\AS-NAS_HR\AmeriFlex Create file failed.
CAUSE
There appears to be a defect in handling Linux restores within Windows which had been introduced into version 10.4.6.
WORKAROUND
We are able to revert the behavior to the pre-10.4.6 code changes which will allow Linux restores to work in Windows as they had previously.
1. Logon to the affected Windows server you attempting to recovery NAS/Linux backups.
2. Open notpad.exe as an Admin
3. Open C:\PCBP\Master.ini from within notepad
4. Under [BProfessional] add the the following:
Extract=No
If present already, change its value from Yes to No.
5. Re-attempt the restore operation.
6. Revert the master.ini changes made above.
It's important to revert the setting to avoid unexpected behavior during typical Windows backups/restores following the recovery.
REFERENCE
https://kaseya.zendesk.com/agent/tickets/6154557
https://kaseya.atlassian.net/browse/ESC-1492
ADDITIONAL INFORMATION
How to Implement workaround via CLI:
1. Obtain current setting (returns empty when not present)
bputil -g -c <asset_name> BProfessional Extract '' master_ini
2. Apply workaround
bputil -p -c <asset_name> BProfessional Extract No master_ini
3. Perform restore via the UI
4. Revert workaround following restore
bputil -p -c <asset_name> BProfessional Extract Yes master_ini