VMware Instant Recovery Fails if Original VM is Online

SUMMARY

Steps to perform VMware Instant Recovery with original VM still in production

ISSUE

VMware Instant Recovery fails while original VM is online.

RESOLUTION

  1. To make sure there is local storage configured for IR, go to Settings > Storage & Retention > Storage Allocation and allocate enough storage for this VM for Instant Recovery.
  2. In the Navigation Pane, highlight the ESX Server (Not the vCenter-RRC) and go to Restore.
  3. Find the point in time for the VM that needs the restore done.
  4. Click Next (Select Options), check Instant Recovery and make sure the virtual machine name has a different name than the original server, should by default come with the VMname_Restore.
  5. Choose the mode that is needed, either Live or Audit mode.
  6. Choose the proper IP Address per the customer’s environment.
  7. Once your mode is set, choose your available ESX server.
  8. Choose the datastore you wish to use.
  9. Click Audit or Restore.
  10. Go to Settings > Instant Recovery > VMware Instant Recovery and wait for the restore to finish.

Once the virtual machine operation is confirmed, Audit mode can be exited by performing the following steps:

  1. Shutdown the virtual machine from the vSphere client interface.
  2. Delete the virtual machine using the vSphere client interface.
  3. Click on Settings > Instant Recovery > VMware.
  4. Click on the job for the selected virtual machine.
  5. Click on Tear Down to allow the system to reset the state of the virtual machine image.

Once the virtual machine operation is confirmed and the data has been migrated to the ESX server datastore, a tear down operation must be performed as follows:

  1. Click on Settings > Instant Recovery > VMware.
  2. Click on the job for the selected virtual machine.
  3. Click on Tear Down to allow the system to reset the state of the virtual machine image.

CAUSE

The 2 VMs will have the same name and IP address, causing the recovery to fail.

NOTES

See also Performing Instant Recovery in the administrators guide.

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