PROBLEM
Receiving an Error on Endpoint: permission denied when running a scan or during deployment.
CAUSE
Antivirus or Firewall might be blocking SM from running.
RESOLUTION
Check if they have an Antivirus or Firewall that might be blocking SM from running. If they are then they must have all recommended exclusions added for all Endpoints.
Exclusions:
- <agent working directory>
- C:\Program Files\Kaseya\
- C:\Program Files (x86)\Kaseya\
- C:\Program Files\Kaseya Remote Control\
- C:\Program Files (x86)\Kaseya Remote Control\
- C:\ProgramData\Kaseya\
- C:\Program Files\Kaseya Live Connect\
The agent working directory, by default, is c:\kworking\ but may have been changed by your VSA administrator. Please review this before setting exclusions.
Additionally, having multiple Kaseya Agents on an endpoint will cause the agent to have multiple agent working directories (ie; c:\kworking1\). Ensure that all agent working directories have exclusions set.
Trusted Apps:
- <agent install directory>\AgentMon.exe
- <agent install directory>\KaseyaRemoteControlHost.exe
- <agent install directory>\KaUsrTsk.exe
- <agent install directory>\DLLRunner32.exe
- <agent install directory>\DLLRunner64.exe
- <agent install directory>\curl.exe
- <agent install directory>\Kaseya.AgentEndpoint.exe
- <agent install directory>\KDLLHost.exe
- <agent install directory>\kGetELMg64.exe
- <agent install directory>\KPrtPng.exe
- <agent install directory>\Endpoint\KaseyaEndpoint.exe
- <agent install directory>\Endpoint\KaseyaRemoteControlHost.exe
- <agent install directory>\Endpoint\KaseyaCommandShellProxy.exe
- <agent install directory>\Endpoint\KaseyaTaskRunnerx64.exe
- <agent install directory>\Endpoint\KaseyaTaskRunnerx86.exe
Trusted Apps for Software Management:
- C:\ProgramData\Kaseya\Data\task\lumension\7za.exe
- C:\ProgramData\Kaseya\Data\task\lumension\analyze.exe
- C:\ProgramData\Kaseya\Data\task\lumension\cabarc.exe
- C:\ProgramData\Kaseya\Data\task\lumension\EnvPrep.exe
- C:\ProgramData\Kaseya\Data\task\lumension\LM.Detection_x64.exe
- C:\ProgramData\Kaseya\Data\task\lumension\OSPXHelper.exe
- C:\ProgramData\Kaseya\Data\task\lumension\qchain.exe
- C:\ProgramData\Kaseya\Data\task\lumension\remediate.exe
The agent install directory is where the Kaseya agent installs. Typically it is installed on C:\Program Files (x86)\Kaseya\<SERVER_GUID> where <SERVER_GUID> is a unique identifier to your VSA. If 64-bit, the install directory will be C:\Program Files\Kaseya\<SERVER_GUID>.