PROBLEM
vPro Remote Control fails to launch KVMView with a "Object reference not set to an instance of an object." message.
CAUSE
This may be caused by an internal KVMView component attempting to write to a log file to a protected directory. The directory chosen is dependent on the browser used to launch KVMView.
RESOLUTION
a) Use a different web browser
b) Enable compatibility mode so that the application can run as an Administrator and write to protected directory. Browse to "C:\Program Files (x86)\Kaseya KVM Viewer", right-click on "KVMView.exe", change to the Compatibility tab and check the "Run this program as an administrator" box
c) Use a tool such as SysInternal's ProcMon to find where KVMView is attempting to create a file named "log.txt" and failing. Grant write access to that path for all local users that would like to run KVMView.
APPLIES TO
Kaseya Desktop Policy & Migration