Network Monitor service does not start automatically after rebooting Kaseya server

Problem

After rebooting the Kaseya server: -

  • Network Monitor views show grey screen with "Network Monitor module has experienced a problem"
  • Kaseya Network Monitor service is not started on server, even though startup type is "Automatic"
  • after starting the service manually, Network Monitor functions normally

knm1.png

 

knm2.png

 

Cause

  • this is a documented problem caused by missing dependency on SQL database
  • if Network Monitor service tries to start before database is available, it will fail

Resolution

Service dependency may be added manually using the following steps (NB, this applies only to installations where SQL Server is running on same server as Kaseya): -

1) on the Kaseya server, open Windows services manager (services.msc) and locate the SQL Server service - usually "SQL Server (MSSQLSERVER)" unless named instance is being used

2) go into properties as copy the service name to the clipboard

knm3.png

 

3) open registry editor (regedit.exe) and navigate to this key: -

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Kaseya Network Monitor

 

4) create new multi-string value here, and paste service name from step 2 into "value data" box

knm4.png

 

The dependency will ensure that, during boot sequence, Network Monitor service does not start until SQL Server is started.

Applies to

Kaseya VSA (Network Monitor) - v7.0 and later

On-premises customers only

 

Ref #88985

Have more questions?

Contact us

Was this article helpful?
2 out of 2 found this helpful

Provide feedback for the Documentation team!

Browse this section