Troubleshooting: Cannot Install Gateway

Problem

No devices appear in the drop down menu to install a gateway.

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Cause

You can only install gateways on Windows agent machines that are also assets and none of these devices are in the Discovery module for that network.

Solution

Navigate to Discovery > Networks > Discovered Devices - Grid View and check the devices listed under the affected network. Make sure that there is at least one asset that is a Windows device with an agent installed. The following screen shows how to read the relevant data to determine this.

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You can install an agent directly on this page by selecting an appropriate asset and then clicking the Deploy Agent button.

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Once there are agents installed, the agent machines will appear in the drop down menu in the Deploy Gateway on Agent page.

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Applicable To

All integrated versions of KNM.

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