KB#: KKB000790
QUESTION
Server public key does not match the public key stored by gateway
ANSWER
Cause:
This error is generated when the public.key file on the gateway do not match the key sent by the server when the gateway connects.
The public.key file (together with the private.key file) is created when you install and configure the server for the first time. The public.key file is one of the four files copied to the gateway host machine. The public.key file is used by the gateway when it connects to the server to verify that the gateway have connected to the correct server, and not a man-in-the-middle server. If you reinstall the server a new public.key/private.key pair will be created, thus invalidating any public.key file found on the already installed gateways.
Solution:
Try to move the public.key file to this gateway again and restart the gateway.
APPLIES TO
Kaseya Network Monitor, KNM