Perfmon continues to run after Kaseya Agent has been removed

PROBLEM
After uninstalling the kasyea agent, performance counters continue to run and you see files such as KLOG$1234.csv being created in c:\kworking on the machine

CAUSE
When you configure Kaseya to collect Windows performance counter logs from a machine, kaseya sends instructions down to the machine that tells windows to create User Defined Data Collection Sets.
This makes perfmon start to collect the information that you have requested and tells perfmon to log the output of this to the CSV files that you are seeing.
This process is a one-time operation - once Kaseya has instructed Perfmon to start creating these logs, Perfmon will just keep running as instructed without further instructions from the Agent.

When you uninstall the Agent from a machine, nothing tells Perfmon to stop collecting these logs.

WORKAROUND / RESOLUTION
Before uninstalling the Kaseya Agent from the machine, be sure to remove the monitor sets that you have applied to the machine. This will instruct the Agent to disable the Perfmon counters and stop the logs being generated.

ADDITIONAL INFORMATION
If you have already uninstalled the Kaseya agent from the machine and wish to stop the logging:

1. log in to Windows on the affected machines
2. load perfmon
3. expand the Data Collector Sets and then the User Defined section
4. stop and/or delete the collectors that are listed

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