Troubleshooting: No Alerts are Generating

Problem

No alerts are generating in Kaseya at all. Or no alerts of a single type are not generating, for example, no agent offline alerts.

Cause

The scheduled agent procedure Run Process Alarms has been removed from the schedule. This may happen after a patch or a maintenance event.

Solution

Navigate to the System > Server Management > Statistics page and click on the scripts link.

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Make sure the Run Process Alarms is listed under Pending Procedures.

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If the procedure is missing or not running (it will be highlighted in yellow and have red lettering if this is the case), please log into the KServer directly and run the "Hotfix and Reapply Database Schema" in the Kaseya program folder.

This will lay down all of the files of the VSA again and reschedule all missing procedures.

Applicable To

All On-Premise installations of Kaseya.

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