PROBLEM
Why does Audit > Installed Apps list is not updated with new application versions after running Latest Audit?
Audit cache (C:\ProgramFiles\Kaseya\Agent\appAuditCache.txt) does list the correct version
CAUSE
The app audit cache on the Agent holds the application list from the most recent run of audit. If it exists, the next audit will only report up differences to minimize the processing load. Therefore a change is reported only once unless the app audit cache is deleted (i.e. reset). When there is no audit cache, the entire list is sent up during the next audit. Possible reasons for missing a reported change would be problems on the server side such as SQL deadlocks, unexpected shutdowns while processing audit results.
RESOLUTION
RESOLUTION
Clear the audit cache on all machines by running the sample Agent procedure script "Reset Audit Cache", then run another Latest Audit.
Allow a few minutes for background processing to complete, then check the Installed Apps list for the updated version.
APPLIES TO
Kaseya Server (all versions)