Problem :
Filtering (Views) agents on the basis of version string of applications (.exe) doesn't return expected results. If you are trying to create a view on the basis of an application's version string. For example all machines with version > x.x.x.x. This doesn't return expected results and the agents ( with defined version ) doesn't appear in the list.
Cause :
When an audit is performed on an endpoint, Kaseya searches the entire drive for all the executables, and lists all the versions that are located on that drive. If a particular exe is located multiple times with different version number, the audit would pickup all of those versions too. When a view is used to filter agents based on application version number, it's applied to all the versions found for that exe in the audit and that may lead to some of the agents not showing up in that view list. There can be many reasons why multiple versions of these exe exist on the the drive, for example, if an application is upgraded using a patch, Microsoft retains the previous version as well so that the application can be rolled back to the previous version if required.
Solution :
Remove unwanted versions from the end point and re-run the audit.
Applies To :
VSA v6.5 and above