PROBLEM
You have found that the SQL transaction logs are quite large or larger than expected
CAUSE
Kaseya itself does not have any control over the transaction log files - SQL creates these and uses these based on its own design.
Whenever a change occurs on the database, SQL records this in the transaction logs. This allows that change, or any other change to be "rolled back" in the event of a problem.
Typically, these are used during a restore of the database.
Imagine that you took a backup of the database on Sunday night. At some point during Monday, there is a problem which leads to the database file being damaged.
Using the Sunday night backup, and the transaction log, you are able to get the database back to the last point before the failure, by "re-playing" all the transactions since the last backup.
A transaction log is only cleared once a successful backup has taken a place and when the database is set to "simple mode".
WORKAROUND / RESOLUTION
Although full details of this process is outside the scope of this KB article, in brief, to "fix" large transaction logs, you need to take a backup of the "ksubscribers" database. This will allow SQL to clear the transaction logs, however this will not automatically free up the space - that will require a shrink - see below
ADDITIONAL INFORMATION
Truncating SQL logs - http://databases.about.com/od/sqlserver/a/truncate_shrink.htm
Shrinking a transaction log that has a lot of free space - http://technet.microsoft.com/en-us/library/ms178037%28v=sql.105%29.aspx
SQL transaction logs are getting very large
Have more questions?
Was this article helpful?
Provide feedback for the Documentation team!
Browse this section
- Add many email addresses in System Monitoring and Alerts
- After updating to new VSA UI, all the icons are missing/distorted
- Alerting when reaching License Limit for KServer
- An error occurred on the server when processing the URL
- Applying a New License Key in Kaseya
- Can I define a scope based on OS Type or Role?
- Cannot Remove Org/Machine Group because there are Agents in it.
- Cannot see some Options in the VSA Toolbox.
- Change Color Scheme with New UI
- Connectwise API Vulnerability
- See more