An error occurred on the server when processing the URL

Problem:

You receive an error message on one or more webpages within the Kaseya interface:

An error occurred on the server when processing the URL. 

Please contact the system administrator.

If you are the system administrator please click here to find out more about this error.

The hyperlink provided therein leads you to a generic Microsoft informational page on IIS and gives no further information on the error

Cause:

Friendly error messages are disabled by default in IIS, the actual, true error ocurring is not being displayed

Solution:

Enable friendly error messages so that we receive a more verbose error message (including an error code). To do so, please follow below steps:

"1) Start an elevated command prompt. Right-click the command shell item in the Start-Accessories menu and select "Run as Administrator". 2) Run the following command: %windir%\system32\inetsrv\appcmd set config -section:asp -scriptErrorSentToBrowser:true"

To disable friendly error messages, after troubleshooting, use this command:

%windir%\system32\inetsrv\appcmd set config -section:asp -scriptErrorSentToBrowser:false"

Have more questions?

Contact us

Was this article helpful?
1 out of 1 found this helpful

Provide feedback for the Documentation team!

Browse this section