Kaseya Application Firewall Service has to be restarted after server reboot

Problem:

After a reboot of the kaseya server, agents do not check-in until the Kaseya Application Firewall service is restarted.

 

Cause:

When the KAF service starts, it looks to the Kaseya Server service to find out what ports to start on.

If the Kaseya Server service has not fully initialised at the time that the KAF service starts, then it will look to its config file for the defaults.

If you are not running on one of these defaults - 80, 443, or 5721, the agents will not be able to check in.

 

Resolution:

Edit \kaseya\services\Kaseya.ApplicationFirewall.config (version 7)

\kaseya\services\KaseyaEdgeServices.config (version 8)

Change the default ports to those that you want to use as defaults, save the file and restart the Kaseya Application Firewall

Upon future reboots, KAF will start on the ports that you have specified.

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