Unable to delete a VSA user from Kaseya

Problem:

When I attempt to delete a VSA user, I get an error, "More than one row was returned for the data document name 'vdb_Users_General'. This usually is a programming error.".

Cause:

A VSA User can not be assigned to two or more staff records; this is by design. There was a bug in KDS that bypassed this restriction and allowed one VSA User to be allowed to two or more staff records. This has been corrected.

Solution:

Verify the latest hotfixes have been applied to the Kaseya Server. Navigate to System Tab > Orgs/Groups/Depts/Staff. Select the Organization that contains the staff records in question and remove the VSA User associated from the staff records until one or none remain.

Applies To :

Kaseya VSA (all versions)

 

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