PROBLEM:
Unable to log into VSA using Internet Explorer (IE). Receive the error > "Cookies are required for logon. Please enable cookies, then refresh this page before proceeding". Other browsers work fine
CAUSE:
This is caused by the VSA not being able to detect the browser correctly due to an issue with Microsoft's .NET Framework.
Microsoft has issued a patch to address this issue.
SOLUTION:
On the Windows server hosting the VSA, please take the following steps:
- Install Microsoft .NET Patch - http://www.microsoft.com/en-us/download/details.aspx?id=42642
Sometimes, the MS Patch does not "cleanup" ASP temp directories, so it is recommended to do the following after installing the patch:
- Stop IIS
- Navigate to C:\Windows\Microsoft.NET\Framework\v4.<<some_number>>\Temporary ASP.NET Files
Delete the contents of that directory (Do NOT delete the folder, just the contents of the directory)
- Navigate to C:\Windows\Microsoft.NET\Framework64\v4.<<some_number>>\Temporary ASP.NET Files
Delete the contents of that directory (Do NOT delete the folder, just the contents of the directory)
- Restart IIS
- Browse to the login page using IE
APPLIES TO:
V7, R8, R9.x
Internet Explorer