Can't backup VM get WARNING: Did not receive any data!! (vprotect log: Could not identify serial port backing type...VirtualSerialPort

SUMMARY

If a VM has the VirtualSerialPort listed as Unsupported, it will cause the backup to fail even if it is not enabled.

ISSUE

Can't backup VM get WARNING: Did not receive any data!!

vprotect logs show the following vprotect_error:
  <vprotect_error>
    <error_message>Backup failed: Could not identify serial port backing type: $VAR1 = bless( {
                 'yieldOnPoll' =&gt; '0',
                 'connectable' =&gt; bless( {
                                           'allowGuestControl' =&gt; '1',
                                           'status' =&gt; 'ok',
                                           'connected' =&gt; '0',
                                           'startConnected' =&gt; '0'
                                         }, 'VirtualDeviceConnectInfo' ),
                 'backing' =&gt; bless( {}, 'VirtualSerialPortThinPrintBackingInfo' ),
                 'unitNumber' =&gt; '0',
                 'deviceInfo' =&gt; bless( {
                                          'summary' =&gt; 'ThinPrint device',
                                          'label' =&gt; 'Serial port 1'
                                        }, 'Description' ),
                 'controllerKey' =&gt; '400',
                 'key' =&gt; '9000'
               }, 'VirtualSerialPort' );
</error_message>
  </vprotect_error>

RESOLUTION

You will need to remove the VirtualSerialPort from the VM. Once this has been done, please perform an Inventory Sync. You can perform the backup after the sync completes.

User-added image

CAUSE

The VMware backup APIs can not perform the backup with the VirtualSerialPort listed.

Have more questions?

Contact us

Was this article helpful?
0 out of 0 found this helpful

Provide feedback for the Documentation team!

Browse this section