PROBLEM
LTR retention policy was edited to remove "weeks" value, and 3 weeks of backups per month were purged
CAUSE
The periods in LTR policies are not cumulative. Each period of time applies to the most recent chain of backups within that time period.
EXPLANATION
A customer had a policy for 7 days, 4 weeks, 3 months, 0 years. They were advised to set Weeks to 0, as that was "not needed." The customer then ignored the dialog box explaining that they were about to delete hundreds of backups by applying this change to the policy.
The periods of time in LTR are not cumulative. If only 7 days were set, then only seven days of backups would be retained. If 7 Days and 3 Months are retained, then only the last seven days plus the last full chain of backups for each of the last three months would be retained. All backups for the last three months that are outside the most recent chain of good backups will be purged.
To put that another way, see the image below.
The above is a text illustration of a Domain Controller's backups as of 11:30 PM on December 18th with a retention policy of 8 Days, 0 Weeks, 3 Months, and 1 Year. This appliance was installed on September 1st. Note that there are 0 backups for October 1st through October 20th. Likewise, there are 0 backups for November 1st through the 22nd.
If the customer's retention goal was the last 90 days of backups. A better policy would be entered as 90 Days, 0 Weeks, 0 Months, 0 Years. That policy keeps the last 90 days of backups, and it is also easier to understand at a glance than the more complex policies in our other examples.
REFERENCE