ISSUE
Cloud archives that leverage cloudadm complete when writing to a brand new bucket. Subsequent attempts fail. We're also unable to mount the storage through the UI.
RESOLUTION
Leverage a live log for the firewall, filtered to traffic going to and/or from the Unitrends device's IP. This will help isolate what component on the firewall is blocking the calls to S3. Once you have this, create a rule or exception to allow traffic to pass.
Watchguard example-
2013-10-02 15:10:59 Deny 192.168.1.255 52.216.81.80 37493 80 1-Armat local 0-External Comcast ProxyDeny: HTTP chunk CRLF tail missing (SocialMedia-HTTP-proxy-00) proc_id="http-proxy" rc="595" msg_id="1AFF-000E" proxy_act="HTTP-SocialMedia" geo_dst="USA" line="HTTP/1.1 200 OK\x0d\x0a"
CAUSE
Firewall is blocking the HTTP/HTTPS commands.