Incremental/Differential Backups Fail After Storage vMotion

SUMMARY

To inform customers that Incremental and/or Differential Backups of VMware VMs would fail if a Virtual Machine (VM) does a Storage vMotion.

ISSUE

 

Consider a VM that is on an Incremental/Differential Backup Schedule. After one or more Incremental/Differential Backups, the VM undergoes a Storage vMotion. After this vMotion, when an Incremental/Differential Backup is kicked off, it fails with an error, which is something like –

---- VProtect Messages ----

Backup failed: Failed to get changed blocks for disk. Remove any snapshots that may exist for the guest: Error getting changed disk areas: FileFault.

This issue may be resolved by removing all snapshots and performing a Full backup of this VM.

SOAP Fault:

-----------

Fault string: Error caused by file /vmfs/volumes/52777fae-f1c474e4-a383-00259091a500/TestVM/TestVM.vmdkFault detail: FileFaultFault

---- End Vprotect Messages ----

For more detailed information on backup failures and performance issues see Unitrends KB 5062 - Backup Failures and Performance Issues

RESOLUTION

There needs to be a new Full Backup of the VM that needs to be taken.

CAUSE

This unexpected behavior is a bug on VMware Side. Unitrends uses VMware APIs to perform these Backups. One of these APIs fails and hence, we get failed Backups. The failure is mainly due to the Change Block Tracking (CBT) information not remaining in sync.

The most common cause of such issues is running on a GA or early release of your vmware ESXi or vCenter versions.  In most vmware editions supported today, running a release that is outdated will result in issues with backups, snapshot management, or CBT failures.  See VMWare's KB on esxi build numbers for ESXi and ensure you are patched to a release newer than these recommended versions:  

- VMware 5.5 patch 10

- VMware 6,0 Express Patch 22 

- VMware 6.5 Express patch 18

- VMware 6.7 update 3b

- VMWare 7.0 update 2a

- VMWare 8,.0 update 

 

NOTES

 

Third-Party Sources

http://kb.vmware.com/selfservice/microsites/search.do?cmd=displayKC&externalId=2035976

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