How to find skipped files in a "Yellow"(warning) backup, non-UTF8 characters

SUMMARY

Describes how to determine what files were skipped and why when a backup job indicates warnings.

ISSUE

Purpose

Describes how to determine what files were skipped and why when a backup job indicates warnings.

Description

Backups may show up with a yellow color in the UI.

 

RESOLUTION

Resolution

Windows:

Check in C:\PCBP\Catalog.dir directory and find the date of the catalog that corresponds to the backup warning/failure.  All files that are backed up or skipped are logged in this file.

Linux/Unix:

Check in /usr/bp/catalog.dir and find the data of the catalog that corresponds to the backup warning/failure.

NAS:
Check on the appliance via putty /usr/bp/catalog.dir and find the data of the catalog that corresponds to the backup warning/failure.
 

[root@MyServer ]# grep -i "Skipping\|non-utf" /usr/bp/catalog.dir/<file_name>
WARNING: @traverse - Non-ASCII characters found in file path...Skipping: /directory/subdirectory/mypath/*file

[root@MyServer ]# grep -i "extended attribute properties" /usr/bp/catalog.dir/<file_name>
WARNING: Failed to retrieve extended attribute properties /directory/subdirectory/mypath/*file

[root@MyServer ]# grep -i "No such file or directory" /usr/bp/catalog.dir/<file_name> 
ctar: cannot open /directory/subdirectory/mypath/*file because...No such file or directory

 

CentOS 6 vs CentOS 7 vs Windows

Under CentOS 7 we have seen where previous backups under CentOS 6.x where parsing special characters as ) vs CentOS 7 shows as " " or ":"
This can lead to unintended "unable to access files" failures when performing NAS backups.
When browsing NAS path in windows the special character we have seen the same characters resolve as "·" in the folder/file name. 


Novell OES (Refer to KB_6090):

The most common cause of a warning is a non UTF8 character in the file name or a corrupt file name.  To find these skipped files you can search for the term ‘Not backed up’ in the catalog.Additionally, files may be skipped because they are “in use.”  Databases and certain other file types may be locked when in use by applications.  The File Level backup agents on most systems utilize services to back up some types of locked files even when they are in use, but other files, including some operating system files, may need to be excluded from normal backups in order for backups to be successful.  Those files can be protected either through Bare Metal backups, application aware agents for databases, or using before/after commands to stop the service using those files.

CAUSE

Cause

The Warning and yellow color in the UI means that the number of items we received in the backup was less than expected. The backup request was successful and we did receive data, but something prevented us from receiving all the data. The most common cause for a backup warning is because a file was skipped.

Reason for skipping:

  • file contained non UTF8 characters
  • file path or name is to long (e.g. 240 characters in Windows or Oracle)
  • file was in use and could not be obtained via another method (via VSS for example)
  • file was held by another process (another backup, antivirus/antimalware)
  • file does not give full access to the local "SYSTEM" user (known as NT AUTHORITY\SYSTEM}
  • file is corrupted
  • media the file is on is failing. 

 

NOTES

The backup itself is still restorable. As long as none of the critical items that are required for the restore were not skipped, your restore options would not be adversely affected. Backups labeled as Warning will not show in the RECOVER > Backup Catalog tab unless you uncheck the Successes box in the FILTER BACKUPS section. You must uncheck the box first, then select the FROM data and any other criteria, then click the Filter button.

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